TypechoJoeTheme

武小栈

武小栈

学习、记录、总结、分享

[分享栈]iview中按需引用组件List、ListItem、ListItemMeta报错

2021-01-29
/
0 评论
/
894 阅读
/
正在检测是否收录...
01/29

1.前言

今天武小栈在用iview时遇到了一个引用错误,Module not found: Error: Can't resolve 'view-design/src/components/list-item' ,折腾了许久之后终于得以解决,其实是一个小问题。

2.正文

先看编译时的报错情况:

提示需要安装这个包,我就想是不是用cli导入的包太老了,不包含这个组件,当我使用npm命令安装最新包的时候依然报这个错误,百度也是无果,只能看下源码了,打开工程目录node_modules\view-design\src\components\list下的index.js文件可以看到:

这下恍然大悟,原来listitem已经被包含到了list组件里面。

只需要这样引用即可。

3.后记

如果对你有帮助,别忘了收藏iview中按需引用组件List、ListItem、ListItemMeta

iview
朗读
赞 · 0
版权属于:

武小栈

本文链接:

https://www.wulinn.com/share/iviewimportlistitemerror.html(转载时请注明本文出处及文章链接)

评论 (0)